BiroTiket

Sunday 9 September 2012

Cara format flash disk di Ubuntu

1. Untuk format ke filesystem EXT3 (Linux) :
$ sudo mkfs.ext3 /dev/sdb1


2. Untuk format ke filesystem FAT (MS-DOS/Windows XP) :  
$ sudo mkfs.vfat /dev/sdb1


note : pastikan flashdisk dalam keadaan umount

Monday 6 August 2012

Download file torrent melalui ssh


Tinggal ketik perintah seperti ini jika OS anda masih dalam turunan debian
           sudo apt-get install screen bittornado

Untuk cek apakah sudah terinstall dengan baik ketikkan
           sudo dpkg -l bittornado

Jika sudah terinstall dengan baik, lalu cara mengunduh file torrent tinggal mengetik perintah
           screen btdownloadcurses http://contoh.com/contoh.torrent

Lalu untuk meninggalkan screen dan membiarkan download tetap berjalan, gunakan kombinasi tombol:
           <ctrl>+<A>+<D>

Untuk menampilkan kembali ketik perintah
           screen r

download file dari mikrotik


kita bikin script di mikotik 

/tool fetch address=ubuntu.com src-path=/download/desktop/thank-you?distro=desktop&release=lts&bits=32;

jalankan scriptnya

script blok torrent


/ip firewall filter
add action=drop chain=forward comment="blokir torrent | www.locomit.com"
disabled=no p2p=all-p2p

Friday 3 August 2012

firewall mikrotik mencegah open proxy


add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128 in-interface=ether4-LoComIT src-address=192.168.1.0/27 comment="proxy-redirect" disabled=no

add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=3128 in-interface=ether4-LoComIT src-address=192.168.1.0/27 comment="" disabled=no

add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=3128 in-interface=ether4-LoComIT src-address=192.168.1.0/27 comment="" disabled=no

/ ip firewall mangle
add chain=prerouting src-address=!192.168.1.0/27 protocol=tcp dst-port=3128 connection-state=new action=add-src-to-address-list address-list=block address-list-timeout=1d comment="" disabled=no

/ ip firewall filter
add chain=input action=drop src-address-list=block comment="drop ip-block"

/ ip firewall filter
add chain=input in-interface=dnsinterface dst-address=IP PUBLIK protocol=tcp dst-port=3128 action=add-src-to-address-list address-list=block address-list-timeout=1d comment=""

Thursday 2 August 2012

script update ddns mikrotik v 5.9 untuk changeip.com


TEST WORK ON MIKROTIK V 5.9


# Set your specific ChangeIP.com preferences here.
:global ddnsuser "username"
:global ddnspass "password"
:global ddnshost "domainname"
:local ddnsport 80

# do not let this script run more than once per 3-5 minutes.

:log info "DDNS: Starting."

:global ddnscheckpoint
:if ([:typeof $ddnscheckpoint] = "time") do={
:log info ("DDNS: Last check was " . ([/system clock get time] - $ddnscheckpoint))
} else={
:log info "DDNS: Cannot determine checkpoint, set now."
:global ddnscheckpoint ( [/system clock get time] - 1d )
}

:if ([/system clock get time] - $ddnscheckpoint > [:totime 180s] || [/system clock get time] - $ddnscheckpoint < [:totime 0s]) do={
   :log info "DDNS: Performing remote IP detection."
   /tool fetch address="ip.changeip.com" host="ip.changeip.com" src-path=("/?" . [/int eth get 0 mac-address ]) dst-path="ip.changeip.com.txt" mode=http port=$ddnsport
   :global ddnscheckpoint [/system clock get time]
} else={
   :log info "DDNS: Please be considerate and wait a few seconds longer."
   :break
}

:global ddnslastip
:local html [/file get "ip.changeip.com.txt" contents]
:local ddnsip [:pick $html ([:find $html "<!--IPADDR="] + 11) [:find $html "-->"] ]

:if ([:typeof [:toip $ddnsip]] = "ip" AND $ddnsip != $ddnslastip ) do={
:log info "DDNS: Sending UPDATE with $ddnsip"
:log info [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ]
:global ddnslastip $ddnsip
} else={
:log info "DDNS: No update required."
}
}


/system scheduler
add comment="changeip" disabled=no interval=5m name=DDNS on-event=\
    updateip policy=read,write,policy,test,password start-time=\
    startup

Friday 22 June 2012

install java di ubuntu 12.04


  • Install Java JDK in Ubuntu 12.04 (Precise Pangolin)
  • Enjoy!
To get started, download Java JDK package from here.
When prompted with the screen below, choose to save the file.

jdk_precise

After saving, extract the downloaded package by running the commands below. This assumes that the package was downloaded in your Downloads folder.
tar -xvf ~/Downloads/jdk-7u3-linux-i586.tar.gz

jdk_precise_1

Next, create a folder for Java JDK files and folders by running the commands below.
sudo mkdir -p /usr/lib/jvm/jdk1.7.0 

jdk_precise_2

Then move all the JDK files and folders to the new location by running the commands below.
sudo mv jdk1.7.0_03/* /usr/lib/jvm/jdk1.7.0/

jdk_precise_3

Next, copy and paste each command as shown below one-at-a-time to enable Java JDK. Remember to press Enter after each line.
sudo update-alternatives --install "/usr/bin/java" "java" "/usr/lib/jvm/jdk1.7.0/bin/java" 1
sudo update-alternatives --install "/usr/bin/javac" "javac" "/usr/lib/jvm/jdk1.7.0/bin/javac" 1 
sudo update-alternatives --install "/usr/bin/javaws" "javaws" "/usr/lib/jvm/jdk1.7.0/bin/javaws" 1

Then create a Mozilla plugins folder in your home directory.
mkdir ~/.mozilla/plugins/

jdk_precise_7

Finally, create a symbolic link to your Mozilla plugins folder. For 64-bit systems, replace ‘i386’ with ‘amd64’.
ln -s /usr/lib/jvm/jdk1.7.0/jre/lib/i386/libnpjp2.so ~/.mozilla/plugins/

jdk_precise_8

That’s it! Enjoy!

Wednesday 20 June 2012

linux ---> mtr

/etc/init.d/network restart

hal yang dilakukan setelah install ubuntu 12.04


install tampilan gnome3



sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update
sudo apt-get install gnome-shell


Apache, MySQL, PHP dan PHPMyAdmin
sudo tasksel



setelah Package Configuration terpanggil, pilih LAMP Server, lalu Ok dan tunggulah hingga proses installasi LAMP selesai.
setelah itu, install phpmyadmin
sudo apt-get install phpmyadmin
JIka Tasksel belum terinstall, klik disini untuk menginstallnya atau menginstall melalui terminal dengan mengetikkan perintah
sudo apt-get install tasksel
Ubuntu-Restricted-Extras
sudo apt-get install ubuntu-restricted-extras
Berikut tambahan agar Ubuntu bisa memutar film DVD
sudo /usr/share/doc/libdvdread4/install-css.sh
Medibuntu Repository
echo deb http://packages.medibuntu.org/ karmic free non-free | sudo tee -a /etc/apt/sources.list

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -

sudo apt-get update
Seputar Kompilasi dan Kompresi
sudo apt-get install unace rar unrar zip unzip p7zip-full p7zip-rar sharutils uudeview mpack lha arj cabextract file-roller

sudo apt-get install build-essential checkinstall cdbs devscripts dh-make fakeroot alien
Gimp 
sudo apt-get install gimp
Ubuntu Tweak
Nah yang satu ini adalah utility yang wajib dimiliki pengguna Ubuntu. Jangan tanya kepada saya apa pentingnya utility ini, pokoknya install saja dan Anda akan mengerti nanti mengapa Ubuntu Tweak ini sangat penting untuk diinstall. Cara menginstallnya adalah dengan cara mendownload pake .deb yang disediakan dalam situsnya di UbuntuTweak.com.
Pastikan Ubuntu Tweak Stable PPA ada di source center Ubuntu sehingga Ubuntu Tweak akan selalu uptodate.

Shutter
Saya termasuk user yang sering screenshot, nah utility paling bagus –menurut saya– untuk melakukan hal ini di ubuntu namanya Shutter. Installasi bisa dilakukan melalui Ubuntu Software Center, atau klik disini, atau dengan menjalankan perintah melalui terminal
sudo apt-get install shutter
Chrome Browser
Dalam repo ubuntu sebenarnya ada Chromium, Chrome Browser versi Open source. Namun saya memilih menggunakan Chrome Browser karena Chromium akhir-akhir ini terlalu banyak melakukan update.

CompizConfig Setting Manager
sudo apt-get install compizconfig-settings-manager
Jika efe-efek desktop yang ada masih dirasa kurang, Anda bisa menginstall plugin extra
sudo apt-get install compiz-fusion-plugins-extra
Editor
  • Geany, digunakan untuk membuat dan mengedit script PHP
  • vim, digunakan sebagai default editor di terminal
  • bluefish editor 
Untuk mengistall Geany dan vim bisa dilakukan melalui Ubuntu Software Center, atau klik disini untuk Geany dan klik disini untuk vim atau langsung melalui terminal
sudo apt-get install geany vim